Older Android apps may stop working after Android P

Developers have found a new class in the latest Android P Dev Preview, which sets a minimum API version. If this is not met by an app, the OS pops up a warning message stating:
"This app was build for an older version of Android and may not work properly. Try checking for updates, or contact the developer."
The current minimum API version set in Android P is 17, which is 4.2 Jelly Bean. We are yet to see if this will remain as a warning in the final version of Android P, or it will block apps from running.

Google has already shown its dedication to bringing the Play Store apps up to date by setting a minimum API support requirement for newly uploaded apps. This way all newly submitted apps should work with the latest Android versions, while the already available ones that fail to update could be retired for good.
Apple has already done a similar thing - it cleaned the App Store from old apps, and if you try running such an app from your iCloud backup it will either pop-up a warning message or won't run at all.
We'll know Google's intentions once Android P goes final.

SHARE THIS

0 comments:

We Love To Hear From You But Don't Spam Us With Links!

Want to be notified when I reply your comment? Tick the "Notify Me" box.